App slow loading
Resolved·Degraded performance

We’ve been monitoring for a while. Everything seems smooth again now

Tue, Nov 18, 2025, 07:53 PM
(2 weeks ago)
·
Affected components
App
Updates

Resolved

We’ve been monitoring for a while. Everything seems smooth again now

Tue, Nov 18, 2025, 07:53 PM

Monitoring

We've fixed the main cause of the slowness - things should be loading zippier again! Some graphs might lag behind, but we're monitoring as things return to usual

Tue, Nov 18, 2025, 06:38 PM(1 hour earlier)

Identified

We noticed that the app is slow and we are working on a fix.

Tue, Nov 18, 2025, 05:17 PM(1 hour earlier)
Powered by